Diesel Forum - All Diesel Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
i have a 99 f250 7.3 on my way home it started to sputter like it was out of gas then died and wont start iam new to a diesel i know about gas engines but not alot bout diesels any ideas?
 

·
Registered
Joined
·
1,448 Posts
Welcome to diesel forums.

You said it died like it ran out of GAS ???? your new to diesels. I hope you didn't just come from the gas station?!?!?!

Have you done any checks since it crapped out on you?
Is the fuel pump still making fuel pressure?
How old is the fuel filter?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
lol i ment it died like it ran out of fuel lol when i went to drain the fuel filter there was pressure there but iam not sure how old the filter is i just bought the truck 3 weeks ago but didnt have any problems
 

·
Registered
Joined
·
543 Posts
Sounds like the HPOP could have taken a crap.

Similar situation happened awhile back with a buddy and his 7.3. We were headed to the drag strip when his truck started sputtering on the freeway. We go off at the exit we needed to take when it just died on him. We tried everything we could on the side of the road. We decided to just pull it to the track and mess with it there. We had several sets of hands workin on the truck to no avail. It would start for a sec or two with ether, but that was about it. He ended up taking it to Rocky, at Rockin S Performance, who informed him the the HPOP was in fact the culprit.
 

·
Registered
Joined
·
543 Posts
Yeah the HPOP ain't the cheapest thing in the world. I would recommend upgrading if it is indeed the issue. My friend, that had his go out, was on his second OEM one, now he runs an Adrenaline pump.

from another site...

There are 2 ways to measure the oil pump's performance.

from another site...

How to check if my HPOP is good



There are 2 ways to measure the oil pump's performance.

If you have access to a scantool, hook it up to the trucks OBD connector, and go to the "datastream"...scroll through the sensor values, until you find ICP (or injection control pressure)...this is your HPOP's "oil pressure".

***NOTE: if you are running any kind of "box" such as the "Edge EZ" or the "Banks Six Gun" you either have to remove the aftermarket jumper harness/plug at the ICP sensor, and reconnect the factory harness by itself. If you are running a home made "10k mod", etc...which plugs/taps into the ICP sensor wires (or connector pins), you will have to remove it as well, or proceed with getting the parts together to run the mechanical gauge, as the scantool will not receive accurate data from the ICP sensor if its signal is being modified from any one of thes "ICP foolers".

To test the HPOP's output, you will be looking on the scantool for the line labeled "ICP" and it's units should be in psi not volts. Some scantools measure ICP in kPa (kilopascals) which you can convert to psi after you take your measurement in kPa.

1kpa = 0.145psi

(for example 19,310kPa = 2800 psi)

Put your chip in its' highest setting, and go out on the interstate (while having someone watch the ICP value on the datastream) and start at about 60mph...

FLOOR the pedal, and stay in it, 100% from ~60-90mph...what you're likely to see (on the scantool) is that the ICP will spike up rather quickly, to 2800-3000psi or so, and then the longer you stay in the pedal...the ICP will slowly drop and drop and drop...the ICP will eventually stabilize (stop dropping).

WHERE the ICP levels off can be some indication as to the condition of your HPOP.

If your truck can maintain 2800+psi then you are one of the FEW folks that have a terrific HPOP.

I would estimate that 90% of the Power Strokes can only maintain ~2200(+/- 200)psi of HPOP pressure, or ICP...5% are above 2600, the other 5% are below 1900psi...


depending on how low (or high) of ICP you are able to maintain will greatly affect which model of injector I would recommend.

If you don't have access to a scantool, then go to your local hydraulic supply house, and have them make you up a mechanical gauge. You might spend $60 or so on high pressure hose, fittings, and a quality 0-3500psi liquid filled gauge....but having this hose available for future diagnostics might be more valuable than you think.

The hose which you will need will need to be about 40" long, rated for (minimum) 3000psi working pressure (12k psi burst rating!) with the gauge on one end, and a #6 female JIC swivel fitting crimped onto the other.

You will also need an individual fitting to screw into the head to go from the head to the hose.

This single fitting will be a 90degree fitting # 5 "male boss" (sometimes called # 5 o-ring) on one end of the 90, and a # 6 male JIC on the other end of the 90. Our local hydraulic shop would label such a fitting as 5MB-6MJ90

"JIC" is nothing special...it's just 'hydraulic talk' for a 37degree flare fitting...standard hydraulic stuff here...nothing rare by any stretch.

Looking at the top of (either) cylinder head, you'll see the factory stainless braided oil lines (one to each head) then you'll see a few bronze colored plugs... (Engine off, of course) Using a 5/8" wrench, remove any one of the bronze plugs, and install the 90deg fitting into the hole. (save the plug for reinstallation , after testing). and the O-rings are reusable, unless brittle, cracked, etc...

The single 90deg fitting will have a "jamb nut" on the O-ring side...screw the fitting into the head, "aiming" the 90 away from the turbo, intercooler pipes, etc...and then tighten the jamb nut, to "squish" the O-ring also locking the 90 from "spinning" around as you attach the swivel end of the hose to the 90. No sealants, loctite, or teflon tape are needed on "JIC" or O-ring fittings...and don't overtighten them...usually about 180degrees with a wrench past finger tight...check for leaks prior to getting too far from home...

run the hose, away from moving parts, electrically conductive junk (like batteries, glow plug relay, starter relays, etc) ..and just route the hose up through the cowl toward the windshield...for short term testing purposes, we just lay the gauge up under a windsheild wiper, and go drive...testing it just like I describes previously...chip in the highest setting, floor the truck, etc....

If you can maintain 2800+ psi of ICP, then any injector 250cc's and under will perform exceptionally well.

If you can maintain 2400psi then that's not bad, not great either.

2200psi is mediocre, and full performance from any injector will not be achieved with that HPOP, though power WILL go up with nearly any injector, driveability (excessive smoke) might be an issue.

If you cannot maintain 1900psi, you might seriously consider an aftermarket dual HPOP system, or our Gen3 HPOP. Nearly any larger injector is going to make the truck feel sluggish, and smoke excessively.


http://www.swampsdiesel.com/content/faq/hpop.htm
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #9 ·
checked voltage at my glow plug relays and had it on one side but not the other crossed it with a screw driver truck started for a min i ordered two new ones of the internet hope it fixes the problem
 

·
Registered
Joined
·
543 Posts
Very cool. Keep us posted.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #11 ·
just wnated to let every one know the glow plug relay did it plus new fuel filter but now i need a new hub for passenger side if it isnt one thing its another lol
 
1 - 12 of 12 Posts
Top