Diesel Forum - All Diesel Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 · (Edited)
Can too much fuel pressure from pusher pump to injector pump cause it not to start? I put new carter pump on truck and after bleeding injector pump and injectors (it still wont start) it buries my fuel pressure gauge (hooked to schrader port). Dont know if I need a pressure regulator or I'm just spitting in the wind. This has been a very aggrevating time with my truck that has performed flawlessly for 11 years and now for almost 3 months has sat in my driveway while I try to get it to run. Replaced fuel tank sending unit, pusher pump and injector pump and it still wont start.I did get a 1694 code the last time I tried. I'm at wits end and hope someone can assist me. :confused:
 

·
Banned
Joined
·
1,488 Posts
Here is the answer to your code.
P1694 indicates that the transmission control module=TCM has no bus signal.
So you need to look at everything from the PCM to the batteries. It might not be recognizing that it's in Park so it wont send the fuel to the injectors. Thats just a guess so I know I might be wrong. Look at the connections to your transmission, and let us know what you find.
 

·
Banned
Joined
·
1,488 Posts
Did you push in the Clutch? You might have to check the safety switches connected to the clutch peddle. Other then that It might be a PCM problem. Something is not right. This is beyond me because I'm not there to really look into it, So please except my apologies. It's not easy to diagnose an issue on a vehicle unseen on the internet. You may have to call around to some shops or try a cummins ram only forum. Thats all I have for you.

There is also the possibility the injection timing might be off?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
Well here it is. After replacing fuel tank sending unit, pusher pump and injector pump, checking all wiring, etc. bleeding injectors no less than 15 times----it was my ECM that had gone south for the winter. New ECM and truck runs like a champ.
 

·
Banned
Joined
·
1,488 Posts
Well here it is. After replacing fuel tank sending unit, pusher pump and injector pump, checking all wiring, etc. bleeding injectors no less than 15 times----it was my ECM that had gone south for the winter. New ECM and truck runs like a champ.
Excellent! What did it take for you to find this problem?
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top