Diesel Forum - All Diesel Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
hello everyone, glad to be somewhere that might be of some help,
1st. problem and most important I have a 1990 250 7.3 that has lost its pressure for starting, I am cranking with gas pedal down and it starts after a min or so cranking , i know the starter is taking a beating. What do you think the problem is or a fix for it?
Can I use ether to help start the engine, until I can fix it? :4-dontknow:



2nd problem--just started 3 days ago, was driving 80 miles and when first started out the tach started jumping up and down 1500-3000rpms without the engine following suit, it was shifting up and down like I WAS taking it from drive to overdrive consistently, i limped it home, by changing from overdrive to reg consistently by pushing overdrive button on and off, what a nightmare. What are your thoughts?
I will be patiently waiting. Thank you, Mike:doh:
 

·
Registered
Joined
·
1,448 Posts
Welcome to Diesel Forums Mike
Glad your here. Enjoy your stay
 

·
Registered
Joined
·
935 Posts
Welcome to Diesel Forums Mike
on your first issue,no, don't use ether to help start your truck. Basicly you could turn your engine into an ether baby.(basicly saying it won't want to start without ether afer a while of using it.)And ether can start burning holes in the pistons.As for the pressure thing, Do you mean it fuel pressure?

As for the second issue,it sounds like the speed sensor is going out. Hopefully someone else will chime in on this.
 

·
Registered
Joined
·
1,837 Posts
is it getting fuel without putting the skinny pedal down while cranking? could be a bad pump or injectors, or even clogged filter. could be glow plugs, or glow plug relay... need more info for whats going on
 

·
Registered
Joined
·
935 Posts
I would start with the simple stuff first.When was the fuel filter changed last? Then i would check the pump next since it delivers fuel to the injectors.
 

·
Registered
Joined
·
5 Posts
I had a 7.3 idi turbo that needed glow plugs, its was a hard started on a cold day. How the weather where your at?
 
1 - 6 of 6 Posts
Top