Diesel Forum - All Diesel Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
hello to yall, sounds a little southern but not really. the reason i found this site was because of my truck, after 384,500 miles i had to replace some o-rings in my oil cooler just under my exhaust manifold, 7.3 diesil. have been very pleased with my truck so far, but i don't know much about it.
\ seems when i removed my cooler i lost my prime. been told i need to remove my oil pan and prime the oil tube with vaseline then start it after refilling the pan with 15 quarts of oil, also told that i can remove 1 bolt on each head to remove the air from the system( don't know where these bolts are for the oil galleys.
so is there anyone out there that can answer and help me to finish my truck?
 

·
Registered
Joined
·
935 Posts
Welcome to diesel forums.You should put your question in the powerstroke section you'll get a better responce.This is the introduce yourself section.
 

·
Banned
Joined
·
1,488 Posts
Welcome DF! Give me a day and I will have a picture for you. It's not hard to spot. These 7.3l will prime them selves. just do your PM (preventive maintenance) I.E. finish your oil change and just cycle the starter couple of times, If it does not start you might have some High pressure or low pressure pump issues, you have two pumps. OR you might have installed a critical o-ring incorrectly.
 

·
Registered
Joined
·
543 Posts
Welcome to DF from Colorado.
 

·
Registered
Joined
·
1,448 Posts
Welcome to Diesel Forums
Enjoy ur stay
 

·
Registered
Joined
·
1,837 Posts
i did not have that issue when i did mine, but of course i drained my oil and changed the filter and filled with 4 brand new gallons of rotella. did you check your oil level?

welcome to the site, and we hope you enjoy your say and come back often to become a valuable member of the forum!
 
1 - 7 of 7 Posts
Top