Diesel Forum - All Diesel Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
935 Posts
Discussion Starter · #1 ·
Lately, i've noticed my headlights pulsing. It's not real bad but it is noticeable.
 

·
Registered
Joined
·
935 Posts
Discussion Starter · #3 ·
No i havn't had it tested.But i was suspecting that. It is the origanal alternator.
 

·
Registered
Joined
·
1,448 Posts
Sounds like your alternator is on it's way out... Does it sound like your engine is turning over a little slower. (weak battery)
 
  • Like
Reactions: 97cummins

·
Registered
Joined
·
935 Posts
Discussion Starter · #5 ·
Sounds like your alternator is on it's way out... Does it sound like your engine is turning over a little slower. (weak battery)
Yea, the engine is turning over a little slower. I do have a battery thats not holding a charge.I need to put on a charger for a couple days.
 

·
Banned
Joined
·
1,488 Posts
Yea, the engine is turning over a little slower. I do have a battery thats not holding a charge.I need to put on a charger for a couple days.
How old are your batteries? If they are close to 5 years old or older, that could be the reason why your alternator is having issues and failing, and the light issues.
 

·
Registered
Joined
·
1,448 Posts
All it takes is one bad battery to drag the other battery down. Turning it into a bad battery.
So have you done any tests since this thread has started? Individual battery load tests? Alternator output test?
 

·
Banned
Joined
·
1,488 Posts
The batteries are optimas and around 3 years old.
Hmm. You should be in good hands then. When those Optima batteries get old they just straight die. No warnings when they go bad. Check your alternator.

Any updates?
 

·
Registered
Joined
·
935 Posts
Discussion Starter · #10 ·
Hmm. You should be in good hands then. When those Optima batteries get old they just straight die. No warnings when they go bad. Check your alternator.

Any updates?
Not yet,i'm going to try and get my alternator tested before i go to work tomorrow.
 

·
Registered
Joined
·
935 Posts
Discussion Starter · #11 ·
Pulled my alternater off today to have it tested and during the test pep boys didn't know that their machine wasn't working right. So I just got another alternator and installed in their parking lot. And after I left,I noticed within 5minutes the Gen light came on. By the time I got back to their place they were closing. I also noticed the volt gauge is reading a lower voltage than the original alternator did.
 

·
Banned
Joined
·
1,488 Posts
Whoa! That's serious! As far as Pep-boys? What? They can't test your alternator? All you needed was a load tester, and somebody that can show you how to use it. Do you have a volt meter?
 
  • Like
Reactions: 97cummins

·
Registered
Joined
·
935 Posts
Discussion Starter · #13 ·
I do have a volt meter and i already used it when i had the origanal alternator.But it was showing 14volts.Pep boys does have an alternator load tester.They used it while trying to load test my alternator,but found out while testing my alternator their mashine wasn't working right.
 

·
Registered
Joined
·
935 Posts
Discussion Starter · #14 ·
I did some studying and discovered that my problem could also be in my pcm.
 

·
Registered
Joined
·
935 Posts
Discussion Starter · #15 ·
Found the problem. I blew the 120amp fuseable link in my pdc. Replaced it now Gen light is gone and reading 14volts.
 

·
Banned
Joined
·
1,488 Posts
I was way off then. Glad you found the problem! Sorry you had to replace an alternator. Like I said It's hard to diagnose something on a truck unseen, And 9 times out of ten it's always something simple. Thank you for sharing.
 

·
Registered
Joined
·
1,448 Posts
Way to trouble shoot... Congratulations of solving the mystery.
Any idea WHY it blow???
 

·
Banned
Joined
·
1,488 Posts
That's an excellent question. He obviously had a power spike at onetime. I should have known better. one time I had a CB, an old but the best Bear cat III Scanner, and the stereo going. Not only did I blow a few fuses during my trip from Oklahoma. I ruined my alternator, and batteries. It was actually a fun trip I blew a tire before I got out into Texas, and the rest happened in Albuquerque NM. I even tried to flag town a local cop, all he did was motion that he would call somebody, I got nothing! I had to push my own Truck out of the intersection! Good thing I had tools.
 

·
Registered
Joined
·
935 Posts
Discussion Starter · #19 ·
I think it it blew when I was installing the new alternator. I forgot to disconnect the batteries and I accidentally got an arc.oops my bad.
 

·
Registered
Joined
·
935 Posts
Discussion Starter · #20 ·
I was way off then. Glad you found the problem! Sorry you had to replace an alternator. Like I said It's hard to diagnose something on a truck unseen, And 9 times out of ten it's always something simple. Thank you for sharing.
(Sorry you had to replace an alternator)
I'm actually convinced the alternator was one of the problems.:smileup:
The headlights aren't pulsing anymore.
 
1 - 20 of 25 Posts
Top