Diesel Forum - All Diesel Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I have a 2009 F-550 and it constantly goes into limp mode and I have had it in the shop about 4 times for this problem and Ford can"t figure it out.
The last time they told me I ran it out of fuel. LOL
 

·
Banned
Joined
·
1,488 Posts
Have you been smoking the tires? That might do it. Ford tries to curb owner abuse. other then that sounds like software issues, or something with a sensor might be causing some problems. If it keeps happening, keep taking it to ford and force them to give you a new truck, or buy you out.
 

·
Registered
Joined
·
317 Posts
i think its time for a dpf delete!!! haha jk sorry to hear about that, take it to ford for a reflash?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #4 ·
No I don't abuse it and it is @ Ford as we speak, they have had it for 4 days now and still no word. They did tell me that I have to keep at least 10% of fuel in the tanks. Other than that I think that they are clueless!!!!!!!!! It only has 50,000mi. on it and has been to 3 different ford shops.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
Well I got my truck back and the only issue they found was a bad connector issue so the replaced that part of the harness but I highly doubt that is the problem but time will tell, will keep you posted.
 

·
Registered
Joined
·
674 Posts
Well I got my truck back and the only issue they found was a bad connector issue so the replaced that part of the harness but I highly doubt that is the problem but time will tell, will keep you posted.

Hopefully, that fixed the problem...keep us posted! :smileup:
 

·
Banned
Joined
·
1,488 Posts
Well I got my truck back and the only issue they found was a bad connector issue so the replaced that part of the harness but I highly doubt that is the problem but time will tell, will keep you posted.
Sometimes it is something simple as a connector. Glad to here read this.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #10 ·
I have been out of town and have not had a chance to drive the truck yet.It might be a while before I know, the last time it did it I drove it for about 2000 mi. before it acted up again. But will post as soon as I know.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #11 ·
Ok will be taking the truck on a 700 mile trip this week and will find out how it does and will post results.
 

·
Banned
Joined
·
1,488 Posts
This will be interesting.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #13 ·
Took the truck to Redding Ca. and back to Portland and it went into limp mode again with about 2500 miles on it since the last time.
Could the cruise control have something to do with it? right before it started to act up I noticed my cruise control did not work. anyway it is at Landmark ford for the 6th time for the same thing and from what I understand there is no lemon law in Oregon. Waiting to hear what they come up with this time.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #15 ·
Ford says that the harness to the fuel sensors is bad so the replaced another part of the harness so we will see how that works. Go figure.
 

·
Registered
Joined
·
1,448 Posts
Woo !!!! I just read the hole thread.. You must be frustrated. I hope this harness fixes it.
 

·
Registered
Joined
·
935 Posts
I'm just throwing this question out.Does your truck have a dpf system? And if it does,when was thet last regen cycle on the exhaust system? Some times when the dpf is to full on a big rig,it will throw the motor into a limp mode. And if it is then the dpf needs to be removed and baked. But some times that won't do any good,and the dpf will need to be replaced. Hope this helps.
 
1 - 17 of 17 Posts
Top