Diesel Forum - All Diesel Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
So here's the story:

[FONT=&quot]My truck was sitting in my Uncle's barn since December 2009 until December 2010 when I got back into the country and picked it up. Well, when I was driving it, most everything was fine, but it would shift really hard into second and almost die on me.
By the time I got it home it was okay, but now, if I start it and attempt to drive it will usually get hung up on sometimes on first, most of time on second, and die. If I let it sit an idle for at least 6 minutes, it will shift at high RPMs into second the first time, and after that be fine. Anything less, if usually dies once, but then after starting it, it will usually be fine.
I'm totally lost at this problem and can't find any good ideas what it might be. Anyone got any ideas?

Thanks!


[/FONT]
 

·
Registered
Joined
·
674 Posts
Sounds like a job for Ed (hawkeye4077)! I will leave a message on his profile page to come check out your thread! :smileup:
 

·
Registered
Joined
·
252 Posts
ha ha ha ha ha ha ha Ops! :D
 

·
Registered
Joined
·
160 Posts
Does there happen to be a check engine light on? Did you check the fluid level ? It sounds like you may have some weak seals in the front pump assembly which are not allowing the pressure to build up quick enough. Once the trans and fluid get warmed up the seals are expanding allowing the pressure to build correctly. What do you mean by 'hung up and die'? Is it going to high or low RPMs whan this happens?
 
1 - 8 of 8 Posts
Top